I had built VTK-8.1.1 and Qt5.12.1.
After installing pyqt, I wrote a simple project and run it, the error message showed that it needs the newer version of Qt 5.15.

So I download Qt-5.15.1 from https://download.qt.io/archive/qt , build it, and install all libraries.

I didn’t find QtCreator app, therefore I installed Qt Creator 4.8.1 (Based on Qt 5.12.1).
Launch the QtCreator app and configure the default kit Desktop, chosen the path of installed qmake for it.

Open an old VTK project in QtCreator, configure the CMake build setting as the following scene.

/usr/local/Qt-5.15.1/lib/cmake/Qt5
/usr/local/Qt-5.15.1/lib/cmake/Qt5Widgets
/usr/local/Qt-5.15.1/lib/cmake/Qt5OpenGL
/usr/local/Qt-5.15.1/lib/cmake/Qt5Gui
/usr/local/Qt-5.15.1/lib/cmake/Qt5Core

/usr/local/Qt-5.15.1/bin/qmake

Build and run the old VTK project.

Categories: QtVTK

0 0 vote
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
A prohibited operation
0
Would love your thoughts, please comment.x
()
x